Archiv pro rubriku: LAN a WiFi

Mikrotik: změna WAN z DHCP na statickou IP adresu

Zakážeme DHCP klienta v IP>DHCP client>ether1-gateway. Pokud by jsme to neudělali a v síti by běžel DHCP server, tak se bude mikrotik snažit načíst adresu z DHCP serveru.

Pro rozhraní ether1-gateway přidáme pevnou IP adresu v IP>Addresses>+

Hodnoty vyplníme dle údajů od poskytovatele připojení.

Dále nastavíme výchozí bránu IP>Routes>+

Dst. Address 0.0.0.0/0
Gateway 188.246.98.97

Dále nastavíme DNS v IP>DNS a zde nastavíme hodnoty dle poskytovatele. Případně můžeme přidat free DNS servery od společnosti Google 8.8.8.8 a 8.8.4.4.

Statické nastavení DNS IP>DNS>Static>Settings pro přidání svých zařízení pro překlad adres.

Share

Mikrotik: LAN jako DHCP server

V našem příkladu budeme chtít, aby nám DHCP server běžel na adrese 192.168.2.1. To provedeme následovně.

  1. změníme rozsah přiřazovaných adres DHCP serverem v IP>POOL>POOLS
    proměnou default-dhcp nastavíme na 192.168.2.200-192.168.2.229

  2. změníme adresu DHCP serveru IP>DHCP server>Networks
    proměnou Adress na 192.168.2.0/24
    Gateway 192.168.2.1
    DNS server 192.168.2.1

  3. teď můžeme změnit adresu rozhraní ether2-master-local na 192.168.2.1
    to provedeme v IP>Addresses
    Address 192.168.2.1/24
    Network 192.168.2.0

Pokud máme vytvořený bridge (např. LAN+WiFi) a chceme na všech rozhraních použít stejný DHCP server, tak musíme nastavit proměnnou interface v IP>DHCP server>DHCP><název DHCP serveru> na bridge.

Nastavení DHCP serveru na bridge

Nastavení DHCP serveru na rozhraní bridge

Privátní rozsahy IP adres

Prefix

První adresa

Poslední adresa

Počet adres

10.0.0.0/8

10.0.0.0

10.255.255.255

16,777,216

172.16.0.0/12

172.16.0.0

172.31.255.255

1,048,576

192.168.0.0/16

192.168.0.0

192.168.255.255

65,536

Share

Mikrotik: WAN jako DHCP client

Základní nastavení je přednastavené již od výrobce (RB750). LAN DHCP server běží na adrese 192.168.88.1. Pokud by vymažete defaultní nastavení a konfigurujete mikrotika ručně, tak nového DHCP klienta na WANu vytvoříme v sekci IP>DHCP client>+. Poté nastavíme interface na kterém DHCP klient poběží.

WAN jako DHCP client

WAN jako DHCP client

Share

Mikrotik: statický DNS a přenesení DNS od poskytovatele

IP>DNS>

Hodnoty vyplníme dle poskytovatele. Případně můžeme přidat free DNS server od google s adresou 8.8.8.8 a 8.8.4.4.

IP>DNS>Static> nastaveni lokálních hostname

Povolit přenesení DNS od poskytovatele pomocí volby Allow Remote Requests.

přenesení DNS od poskytovatele

přenesení DNS od poskytovatele

Share

Mikrotik: SNTP klient (automatické nastavení času)

SYSTEM>SNTP Client

Zašktrknout „enabled“, přepnout mód na „unicast“ a nastavit servery na:

64.236.96.53

ntp.nic.cz (217.31.202.100), time-nw.nist.gov (131.107.13.100), ntp.amnic.net (195.43.74.123)

SYSTEM>Clock

a nastavit „Time zone“ na „Europe/Prague“

/system clock
set time-zone-name=Europe/Prague
/system ntp client
set enabled=yes primary-ntp=217.31.202.100 secondary-ntp=131.107.13.100
Share

Mikrotik: změna hesla administrátora

Klikneme na „System>password“ a zadáme staré a nové heslo.

Změna hesla

Změna hesla

Share

Mikrotik: export a import konfiguračního souboru a záloha konfigurace

Export a import konfiguračního souboru

Pokud potřebujeme vyexportovat nastavení mikrotiku v textové podobě lze použít příkazy export a import. Možnost tohoto exportu oceníte při přenosu nastavení na jiný typ routru mikrotik. Případně pokud hledáte chybu v nastavení, tak zjistíte všechny změny od defaultního nastavení.

/export compact file=nazev-souboru
/import nazev-souboru.rsc

Ve složce Files vznikce soubor nazev-souboru.rsc kde jsou veškerá nastavení.

Import rsc souboru

Import rsc souboru

Záloha nastavení

Pokud provede zálohu nastavení pomocí nabídky Files>Backup tak se vytvoří binární soubor který obsahuje všechna nastavení a data. Je to ideální nastavení pokud měníte kus za kus. Ale pokud chcete použít stejné nastavení na jiném mikrotiku potažmo v jiném místě dejte si pozor na to že automaticky dojde k přenastavení MAC adress dle původního mikrotiku. Vymazat nastavení MAC adresy lze v Interface>název-připojení a na záložce General klikneme na tlačítko Reset Mac Address.

Share

TFTP server TFTPD32/64

Občas pro přehrání firmware nebo zavaděče je potřeba TFTP server. Mě se pro svou velikost a jednoduchost osvědčil TFTPD32 případně TFTPD64. Můžete jej stáhnout na adrese http://tftpd32.jounin.net.

Po stažení a rozbalení archívu spustíme na 64bitovém systému tftpd64.exe. A následně nastavíme tftpd64.

TFTP server nastavení

TFTP server nastavení služeb

TFTP server nastavení cesty a vybrání síťové karty

TFTP server nastavení cesty a vybrání síťové karty

Syslog

Syslog

TFTP server nastavení cesty a síťové karty

TFTP server nastavení cesty a síťové karty

Share

Obnova firmware NAS Iomega ix2-200

Pokud se Vám stane, že se nemůžete připojit na Iomega ix2-200 a pouze bliká bílá LED dioda, tak pravděpodobně došlo k poškození firmware v NAS. To se mohlo stát v důsledku poškození disku nebo chybným přehráním FW. V článku najdete popis opětovně zprovoznit NAS.

Upozornění:

vždy si zazálohujte data
všechny činnosti provádíte na vlastní nebezpečí
autor článku nepřebírá odpovědnost za jakoukoli způsobenou škodu

Co budeme potřebovat:

Převodník RS232 na TLL nebo USB na TTL
TFTP server, mě se osvědčil http://tftpd32.jounin.net
Flash disk o velikosti minimálně 2GB a formátovaný na FAT32
Nešifrovaný firmware
zImage a initrd na TFTP serveru

FW ix2-200 3.2.6.21659
http://downloads.iomega.nas-central.org/Users/Mijzelf/ix2-200/
FW ix2-200d 3.1.14.995
https://www.sendspace.com/file/r0ego5

Pokud máte disk, který byl už někde použtý, musíte jej vymazat. Asi nejspolehlivější způsob bylo použití programu diskpart ve Windows. Připojíme disk až už přímo na SATA nebo pomocí USB redukce. Spustíme v příkazové řádce cmd program diskpart. Zobrazíme disky v PC příkazem list disk. Následně vybereme disk pomocí příkazu select disk <cislo disku> a následně jej příkazem clean smažeme. Tím máme disk připravený a můžeme jej zapojit do NAS.

Na USB flash disk nahrajeme soubor *.tgz. Někdy bývá ještě zabalen do zip nebo rar. Pak je nutné jej rozbalit a dle verze ix2 jej uložíme do složky:

/usb_drive/emctools/ix2-200_images/*.tgz
/usb_drive/emctools/ix2-200d_images/*.tgz

Aby jsme mohli pomocí TFTP nahrát zImage a initrd rozbalíme archív a tyto dva soubory umístíme do adresáře pro TFTP server. Sputíme TFTP server. Takto nachystanou flash zasuneme do USB portu v NAS.

Připojíme převodní RS232toTTL na pin JP1 a to:
pin 1 = Vcc 3,3V
pin 2 = TxD
pin 3 = GND
pin 4 = RxD

www.brianhoskins.uk/wp-content/uploads/2013/08/JP1_2.jpg

Spustíme program Putty a začneme odchytávat konzolu na COM4. Číslo COMx musí odpovídat COM portu na vašem PC.

Putty zachytávání COM

Putty zachytávání COM

A teď už připojíme napájení NAS storage. Po několika sekundách se objeví v terminálu hláška Hit any key to stop autoboot. Zmáčkněte jakoukoliv klávesu. Tím spustíte rozhraní Marvell. Spustíme TFTP server na počítači (defaultní IP adresa pro server 192.168.1.100, IP zařízení 192.168.1.11)

Změna adres TFTP klienta na NAS a TFTP serveru

setenv ipaddr 192.168.100.10
setenv serverip 192.168.100.11

Načtení zImage a initrd

tftpboot 0x2000000 zImage
tftpboot 0x5400000 initrd
nand erase 0x100000 0x300000
nand erase 0x540000 0x300000
nand write.e 0x2000000 0x100000 0x300000
nand write.e 0x5400000 0x540000 0x300000

boot

Po nabootování se NAS automaticky vypne. Výpis v konzoli končí výpisem Writing data to block 25c000 Remove the temp folder. Remove the temp folder.

Vytáhnout USB flash disk a spustit NAS.

Vyhledání IP adresy NAS v síti podle MAC adresy začínající 00:D0:xx:xx:xx:xx:

arp -a

Připojit se na NAS a znovu jej nakonfigurovat. Případně vyzkoušet upgrade na nejnovější FW, ale to už jsem neměl čas vyzkoušet.

Odkazy:
http://nas-central.org
http://iomega.nas-central.org/wiki/Category:Ix2-200
http://forum.nas-central.org/viewtopic.php?f=243&t=8671
https://zepman.tweakblogs.net/blog/3552/iomega-ix2-200-bad-flash-recovery-and-hdd-replacement.html
http://lars.karlslund.dk/2011/11/recovering-iomega-ix2-200-nas-after-failed-upgrade/
http://brianhoskins.uk/hardware-hacking-the-iomega-storcenter-ix2-200/

Starší ix2 zařízení s verzí FW nižší než 3.3.2 nemůžou být aktualizované na verzi 4.1.212.33882.
Manuál http://download.lenovo.com/nasupdate/manuals/ix2-200_cloud/ix2-200_en.pdf
Nejnovější FW https://lenovo-na-en.custhelp.com/app/answers/detail/a_id/31178
Minimální verze pro upgrade na nejnovější 4.1.212.33882 http://download.lenovo.com/nas/lifeline/ix2-ng-4.0.2.9960.tgz
Storage manager https://lenovo-na-en.custhelp.com/app/answers/detail/a_id/26106/related/1

Share

Mikrotik: netinstall aneb oprava RouterOS

Stáhneme si Netinstall a stabilní firmware. Propojíme PC s RB UTP kabelem do portu LAN1. Na síťové kartě nastavíme např. adresu 192.168.88.3. V Netinstall klikneme na položku NetBooting, povolíme položku Boot server enabled a nastavíme IP adresu např 192.168.88.2 kterou chceme přiřadit mikrotiku. Odpojíme napájení od Mikrotiku a zmáčkneme tlačítko reset. Za stálého držení připojíme power a držíme 15s (zhasne LED dioda USR). Poté by jsme měli Mikrotik vidět v aplikaci Netinstall. Pomocí Browse nalistujeme adresář s firmware . Z nabídky vybereme firmware, který chceme použít a spustíme instalaci kliknutím na tlačítko Install.

Mikrotik netinstall

Mikrotik netinstall

Mikrotik netinstall

Mikrotik netinstall

Po úspěšném přehrání RouterOS je potřeba mikrotik restartovat s novou konfigurací. Čili odpojit napájení a podržet reset po dobu 5 sekund po připojení napájení.

A následně proveďte upgrade firmware v System routerboard.

Share