Firefox v52.0 konec podpory NPAPI pluginů Hikvision, W Box atd.

Firefox ve verzi 52.0 končí s defaultní podporou pluginů NPAPI kromě pluginu pro Flash. Z tohoto důvodu od této verze Firefoxu nejdou spustit pluginy pro například pro kamery, kamerové systémy, NVR zařízení atd. Postiženy jsou například kamery a NVR zařízení firmy Hikvision, W box …

Dočasně lze vynutit povolení NPAPI pluginů přidáním proměnné plugin.load_flash_only typu Boolen/Logická hodnota s nastavenou hodnotou na False v pokročilém nastavení Firefoxu.

Návod:

Spustíme Firefox a do adresní řádky napíšeme about:config a dáme enter.

Povolení NPAPI pluginu ve Firefoxu v52

napíšeme about:config do adresního řádku

Potvrdíme upozornění o úpravách na vlastní nebezpečí.

Povolení NPAPI pluginu ve Firefoxu v52

Potvrdíme upozornění.

Klikneme pravým tlačítkem myši do pole s proměnými a v kontextové nabídce vybereme Nová předvolba>Logická hodnota.

Povolení NPAPI pluginu ve Firefoxu v52

Vytvoření proměnné plugin.load_flash_only

Vyplníme název proměnné plugin.load_flash_only a nastavíme hodnotu na False.

Povolení NPAPI pluginu ve Firefoxu v52

Vytvoření proměnné plugin.load_flash_only

Povolení NPAPI pluginu ve Firefoxu v52

Nastavení hodnoty na False

Teď už stačí jen restartovat Firefox a plugin bude funkční. Toto řešení je bohužel jen dočasné a mělo by fungovat do verze 59. O ukončení podpory NPAPI pluginů informovala společnost Mozilla v říjnu 2015. S tím že, ukončení podpory NPAPI pluginů nastane koncem roku 2016. Pro zajímavost Chrome ukončil podporu NPAPI pluginů v září 2015.

Dalším řešením je použití prohlížeče Internet explorer, předchozí verze Firefoxu, nebo instalace některého z forků programu Firefox s prodlouženou funkčností NPAPI pluginů. Seznam prohlížečů na bázi Firefoxu bez ověření funkčnosti NPAPI https://en.wikipedia.org/wiki/Category:Web_browsers_based_on_Firefox.

Prohlížeče s podporou pluginů NPAPI:

https://www.palemoon.org/

Share